Back to overview
Resolved

Email delivery issues

Jun 29, 2026 at 6:32am UTC
Affected services
Portal

Resolved
Jun 29, 2026 at 10:46am UTC

The email delivery issue has been resolved. Messages are now sending and arriving normally.

If you reached out during this time and haven't heard back, please try again through the help widget in our platform.

Thanks for your patience.

Created
Jun 29, 2026 at 6:32am UTC

We're aware of an issue that may delay or prevent some email messages from reaching you. We're working on a solution and expect to have it resolved soon.

In the meantime, you can reach us through the help widget in our platform.

Thanks for your patience.