Scheduled platform maintenance
Resolved
Jun 27, 2026 at 9:52am UTC
Maintenance ended
Affected services
Updated
Jun 27, 2026 at 9:52am UTC
Maintenance is complete and the platform is back online. The migration to our new portal finished as planned.
If you run into any trouble signing in or accessing your account, reach out through the help widget in our platform and we'll sort it out.
Thanks for your patience while we made these improvements.
Affected services
Updated
Jun 27, 2026 at 9:10am UTC
We're wrapping up the final steps of the migration. Everything is on track to finish at the planned time. The platform will be back online shortly, and our website and all other services remain fully operational.
Thanks for your patience.
Affected services
Updated
Jun 27, 2026 at 5:22am UTC
Maintenance is now underway. Access to the platform is temporarily unavailable while we complete the migration. Our website and all other services remain fully operational.
We'll post another update as soon as the platform is back online. Thanks for your patience.
Affected services
Created
Jun 27, 2026 at 5:00am UTC
We will be performing scheduled maintenance on our platform on Saturday, June 27, 2026. During this time, access to the platform will be temporarily unavailable. Our website and all other services will remain fully operational.
We apologize for any inconvenience and appreciate your patience as we complete these improvements.
Affected services