Back to overview
Degraded

Automated processing delays

Jan 19 at 12:45am CET
Affected services
Portal

Resolved
Jan 19 at 05:31am CET

The issue causing delays in automated processes has been resolved. Automated actions such as ISBN assignment, welcome emails, and password resets are now processing normally again.

We will continue to monitor the system to ensure stability.

Created
Jan 19 at 12:45am CET

We are currently experiencing delays in some automated processes due to an ongoing issue at our backend provider.

This may affect automated actions such as ISBN assignment, welcome emails, and password reset emails. Manual actions and access to existing accounts remain available.

The provider has identified the underlying configuration issue and is awaiting manual database cleanup by AWS to fully resolve it. We are monitoring the situation closely and will update this page once normal processing has resumed.