Back to overview
Degraded

Cover upload service degradation

Dec 16 at 12:15am CET
Affected services
Portal

Resolved
Dec 16 at 04:11am CET

The issue affecting cover uploads has been resolved. Upload functionality has returned to normal, and new uploads should now process as expected.

We will continue to monitor the system to ensure stability.

Created
Dec 16 at 12:15am CET

We are currently experiencing delays and intermittent failures when uploading book covers. This is caused by an ongoing issue at our file upload provider.

An initial fix was implemented by the provider earlier, but upload performance remains degraded and they are actively investigating and working on a full resolution. During this time, uploads may be slow, time out, or appear not to complete.

We are monitoring the situation closely and will update this page as more information becomes available.