Back to overview
Degraded

Degraded Performance

Mar 31 at 11:19am CEST
Affected services
Portal

Resolved
Mar 31 at 04:04pm CEST

The issue has been identified and resolved. Thank you for your patience.

Created
Mar 31 at 11:19am CEST

Some users may experience slower load times on the portal. We’re investigating and will share updates as available.