Back to overview
Downtime

Downtime

Oct 14 at 02:00pm CEST
Affected services
Portal

Resolved
Oct 14 at 02:10pm CEST

We're back! Our portal is up and running again. Thanks for bearing with us.

Created
Oct 14 at 02:00pm CEST

Our portal is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.